Video Processing Tools

Программа захвата, просмотра и обработки видео данных. Программа предназначена для просмотра видео информации в условиях малой освещенности объектов наблюдения.

Требования к среде выполнения:

Операционная система Microsoft Windows NT (2000/XP или выше), Microsoft® DirectX 8 или выше. Процессор Pentium III или выше.

  • Возможности программы.

  • Описание программы.

  • Дополнительные возможности.

  • Список Горячих клавиш.

  • Решение возникающих проблем

  • Изменения в программе (changelog).

  • Страница программы. Поддержка.

  • Страница САО

Загрузка программы:

программу можно загрузить с Интернет сайтов:

http://www.sao.ru/hq/slkom

http://fviz.narod.ru

там же можно найти информацию об обновлениях программы.

mArtStudio 2005, support


Возможности программы:
  • Программа позволяет просматривать видео потоки в двух окнах - окне "живого видео" - без обработки и окне накопленного изображения.
  • В регулировать яркость (Усиление/Amplification), уровень черного (Black Level) и гамму (Gamma). Этих параметров обычно достаточно для установки комфортного просмотра изображений с низкой освещенностью объектов.
  • В ручную задавать число кадров для сложения (Accumulator) и задержку считывания кадра. Задержка считывания кадра необходима при использовании видео камер со встроенным накоплением. (В этом режиме камера автоматически или в ручную проводит накопление на аппаратном уровне.)
  • Использовать, где это необходимо и возможно дополнительную обработку (удаление горизонтальных и вертикальных помех (полос) и др.)
  • Вычислять, визуализировать и устанавливать геометрический центр объекта наблюдения используя выбранные каналы.
  • Сохранить отдельные кадры из полученного видео потока. Имя файлов задается шаблоном. Количество кадров и задержка между сохраняемыми кадрами так же управляется.

mArtStudio 2006, support


Описание программы

Специальная Астрофизическая Обсерватория

Описание программы:

Окна программы и их краткое описание:

главное окно программы

Окна просмотра:

(камера с накоплением)

(webcam)

кнопки убрать/показать окна просмотра:

Кнопки управления :

Пуск, Пауза, Стоп:
Сохранить изображения:
Сбросить параметры по умолчанию:

Автоматический режим подстройки параметров.

  1. АвтоУсиление,
  2. АвтоНакопление,
  3. АвтоЗадержка.

Удаление шума и градиента (горизонтальное/вертикальное)

Задержка (время - СЕК:МС)

Сложение кадров:

  • Количество суммируемых кадров.
  • Задержка - число пропущенных кадров и время Delay (зависит от fps).

Кнопка [image] - "сбросить по умолчанию", слайдер, кадры.

(пример накопления изображений)

(настройки)

Задержка:

Необходима для камер с накоплением. Правильный выбор задержки для таких камер (разумеется при накоплении более 1 кадра) позволяет повысить соотношение сигнал/шум. При этом в среднем суммируются различные кадры (в пределах времени накопления камеры данные подвержены только шуму передающей линии и не суммируются). Удаленное управление временем накопления камер не поддерживается (не реализовано) в программе, так что приходиться выбирать задержку, исходя из дополнительных соображений (например, интенсивности) или визуального теста смены кадра (в первом окне программы). Автоматический выбор задержки пока реализован для камеры используемой при тестах программы и может не соответствовать установкам реальной камеры или условиям наблюдения (более интеллектуальный алгоритм будет реализован в следующей версии программы).

Начальная обработка кадров:

Результирующая интенсивность вычисляется над сложенными кадрами (см.Сложение кадров)
Статистические и прочие вычисления проводятся уже с результирующей интенсивностью и зависят от данных параметров (что позволяет, например, выставить удовлетворительный режим вычисления геометрического центра объекта при слабой освещенности).

(меню обработки)

В пункте меню - "Каналы" - можно выбрать, какие каналы идут на обработку и будут визуализированы. Все вычисления затем проводятся с этими данными. Например, при выборе красного канала, вычисление геометрического центра объекта будет производиться только в красном канале.

Вне зоны обработки показываются либо все каналы, либо выбранные.

(Накопление)

В пункте меню - "Накопление" - можно выбрать алгоритм накопления кадров. Если выбран алгоритм с вычитанием фона, удобно использовать автоматическую подстройку усиления -
пункт меню "Автоподстройка Усиления" или кнопка

(Область обработки)

В пункте меню - "Область обработки " - можно настроить область обработки,

а также переключиться в один из режимов редактирования области (прямоугольник) с помощью мышки в окне показа обработанного видео. Эти пункты меню доступны по щелчку правой клавиши мыши в окне обработки:

(редактирование области обработки)

Остальные пункты меню повторяют кнопки управления (Сложение кадров ).

Меню выбора источника видео данных и параметры:

Верхние пункты меню - устройства ввода видео данных.
В данном примере два устройства.
Следующие пункты меню - параметры выбранного устройства.
Для правильного отображения видео данных необходимо выбрать: источник, формат и видео стандарт. Вызываемые окна зависят от устройств и установленных в операционную систему драйверов...

(пример окон контроля для webcam)

Следующие пункты меню (если существуют) - настройка видео тюнера, быстрый выбор источника видео данных и другие.

"Поиск центра объекта".
Совмещение центра объекта с центром визуализации:

В этих пунктах меню можно разрешить вычисление центра объекта и его визуализацию.

Данные действия имеют смысл при наблюдении локализованного обьекта, у которого имеет смысл вычислять его геометрический центр. Например,

guide1:

объект с вычисленным геометрческим центром
(2 окна программы)

вычисление "центра тяжести объекта"

Пункт меню - "Перемещать зону обработки" - включает режим перемещения зоны обработки чтобы удержать объект в зоне захвата.

Можно включить "виртуальное" гидирование объекта (пункт меню "Симуляция гидирования"), заключающееся в помещении центра объекта в центр системы координат изображения.

симуляция гидирования (удержание объекта в центре окна)

Для настройки параметров вычисления геометрического центра объекта (пункт меню "Настройки...") вызывает окно диалога:

Пункты меню "Вид"...

В данных пунктах меню можно открывать или закрывать окна просмотра изображения, статистики, изменять размер, а также управлять отрисовкой осей и зоны обработки.

(окно статистики)

Окно диалога выбора каталога и параметров для сохранения серии изображений:

1. В этом окне можно отредактировать шаблон по которому строиться имя записываемого файла.
Формат шаблона:

  • #текст - поставляется 'текст',
  • %n - подставляется имя устройства,
  • %t - подставляется время кадра,
  • %f - поставляется номер кадра.

2. Строка каталога для сохранения изображений

3. Количество кадров, которые будут сохранены.

4. Количество пропущенных кадров и соответствующее время.

Пункты меню "Помощь":

Данные пункты меню предлагают помощь.

Если есть проблемы замедления работы программы (пропущенные кадры, медленный отклик и т.п.) можно использовать панель помощи:

отдельные переключатели которой позволяют перенастроить работу программы (однако, данные действия можно выполнить и "в ручную"...)

mArtStudio 2006, support


main

Дополнительные возможности.

Автоматические режимы:

В автоматическом режиме устанавливаются следующие параметры:

  1. Количество суммируемых кадров в группе кадров.
  2. Задержка суммирования.
  3. Усиление - увеличение или уменьшение яркости изображения.

автоматическое регулирование каждого из этих параметров может быть раздельно включено или выключено.

"Сброс по умолчанию" позволяет запустить процесс авторегулирования "к началу", что бывает полезно при быстро меняющихся условиях освещенности. Ручное регулирование в автоматическом режиме так же возможно - при этом такое регулирование имеет тот же смысл сброса параметров.

Проигрывание видео файлов:

vproc.exe имя_видео_файла

Запуск программы с параметром - именем видео файла - позволяет просматривать сохраненное видео. При этом вся обработка так же выполняется. Это бывает полезно при просмотре сохраненного другой программой видео - имитируются режим "живого просмотра" с видео камерой.


Краткое описание используемых алгоритмов.
Входной поток данных, представляющих собой последовательность видео кадров, разбивается на группы. Обработка проводиться с каждой группой кадров (изображений) отдельно. Изображения в пределах каждой группы суммируются, что позволяет улучшить соотношение сигнал-шум. Далее, полученное изображение обрабатывается, вычисляются его статистические характеристики. Из полученных изображений собирается новый видео поток. Вычислительный процесс организован по типу конвейерной обработки.Результирующая интенсивность вычисляется над сложенными кадрами I(x,y) = round(gamma(level + ampl * SUM i(k) / N, g)),
где
N - количество суммируемых кадров,
i(k) - выбранные, с учетом задержки (Delay) кадры i(x,y),
k = 1, ... N,
gamma(i, g) = A * pow(i/A, g) - степень контрастности изображения
Поскольку вычисления проводятся с большей разрядностью чем принимаемые кадры, то они слабо чувствительны к переполнениям, шумы вычислений так же малы. Статистические и прочие вычисления проводятся уже с результирующей интенсивностью и зависят от данных параметров (что позволяет, например, выставить удовлетворительный режим вычисления геометрического центра при слабой освещенности, увидеть слабый объект).


Список Горячих клавиш.

Запуск просмотра: | Пробел [Space]
Останов: | Ctrl+S
Пауза: | Ctrl+U
Убрать/показать окно необработанного видео: | F4
Сохранить изображения: | F10


Проблемы и их решение

  • Программа не запускается, требуется некий файл...
    Возможное решение: причина - не установлен Microsoft® DirectX версии 8 или 9.
    Установить пакет.
  • Нет устройств захвата видео.
    Возможное решение: причина - устройства отсутствуют в операционной системе, необходимо установить драйверы (или проверить железо).
  • Изображение есть, но какое то странное...
    Возможное решение: настроить видео стандарт.
  • Программа работала, но теперь не работает.
    Возможное решение: причина - запущена другая программа показа видео - устройство захвачено. Выйти из этой программы.
  • Работа программы замедлилась...
    Возможное решение: причина - "медленный процессор", например Pentium 2 (рекомендован P4). Отключить окно просмотра "живого видео". Использовать панель настройки в системном меню "Помощь".
  • Программа зависла.
    Возможное решение: причина - ошибка разработчика, отправить письмо с описанием ошибки на slkom@sao.ru . Попытаться скачать свежую версию программы на сайте разработчика http://www.sao.ru/hq/slkom . Возможно, данная проблема уже замечена и ошибка исправлена.
mArtStudio 2006, support